前端开发 ·

Vue和vue-template-compiler版本不符

最近在初学习vue,搭建Element脚手架element-starter,在 npm run dev 的时候提示异常报错

猜测原因:估计在更新或者安装其他依赖库的时候,同时两者中的一也随着更新了,导致了两者的版本不符。

我们主要看这句话就可以了,已经明确告诉你这两个版本不一样,需要你去做更新。

This may cause things to work incorrectly. Make sure to use the same version for both.
If you are using vue-loader@>=10.0, simply update vue-template-compiler.
If you are using vue-loader@<10.0 or vueify, re-installing vue-loader/vueify should bump vue-template-compiler to the latest.

两个不同的版本号

- vue@2.5.16
- vue-template-compiler@2.5.2

解决方法

npm install
npm update

在执行npm update没有任何提示的话,代表没更新了。

这时候再去npm run dev ,看到 webpack: Compiled successfully. 代表成功,就可以正常跑起脚手架了

 

参与评论